Monthly Archives: June 2015

A new discovery!

Today I’ve made a new discovery. Oasis Mighty Drops Raspberry Lemonade

rl

I will be buying more from Tesco!!!  That is all.

vt-x problems with MSI ClickBios II and VMWare Workstation

Having decided to have a play with Cisco’s VIRL solution, I’d intended to set it up on an old Laptop that I had laying around, but the requirement for a minimum of 4 CPU Cores, vt-x support (for Hardware assisted Virtualisation) and no less than FIVE Network Interfaces, I decided that I’d be better off using VMWare Workstation instead.  VIRL doesn’t run under VirtualBox so VMware it is.. One license purchase later, and I’m merrily installing it on my Core i7 3820 machine, with plenty of RAM, Disk space, under 64-bit Windows 8.1, no problem!  or so I thought!

I vaguely remember having issues with VirtualBox and the hosting of 64-bit Guest OS’es before, but since my need at the time wasn’t too specific, I didn’t really spend the time trying to resolve it, but I was surprised to find once installed, that VMWare Workstation 11 was nagging me that a 64-bit guest OS was not supported on my machine.  I’d checked the pre-requisites quite carefully.

Of course I Googled, quite extensively, and didn’t find much that described my exact issue.  and yes, I checked in my BIOS that the Hardware Virtualisation settings were enabled (they were!);  I was definitely running a 64-bit OS, so why would it not work.  My CPU, an i7 3820 definitely supported the Virtualisation extensions, but the Intel Processor Identification Utility stubbornly disagreed!  My rig is a 2-3 year old custom build from Mesh Computers, based on an MSI X79A-GD45 main board.  There should have been no issue with Virtualisation, and there was certainly no issue with running 64-bit Windows on it!

After much research, I stumbled on an article from VMWare dated December 2008 that suggested that VT-X was often unavailable to normal software if “trusted execution” was enabled.   That sent me off in to the ClickBIOS once more as I recalled seeing a setting for an “Execute Disabled Bit” which was ON, so I decided to try turning it off and see what happened.  I’ve attached the in-windows screenshot of the BIOS simply because it’s easiest to capture, but the setting was found in the same place at boot time.

cb2

It was tucked away under Overclocking Settings, and CPU Features, just before the Intel Virtualisation Tech and VT-D Tech options.  Sure enough, disabling this caused VMWare to be quite happy with a 64-bit guest OS, and the Intel CPUID tool also now claimed that I was capable of Virtualisation.

cpuid

PROBLEM #1 Solved!

Next step will be downloading and installing VIRL itself within a Virtual Machine.  That’s a story for another day!

6 Months Later…

Okay, so I’m not very good about keeping my promises to post on here more often!! Hopefully that’s about to change, and more about that in a few minutes.

Quite a bit has happened since I last posted. Most particularly of note would be the delivery of my nice shiny new car on 20th May, closely followed by me and it being #3 in a 4 car sandwich no less than 20 days and 1046 miles later. As I write this post, the car is still with the repairers, and I’ve now been driving the courtesy car for as many days as I’ve driven the Mercedes!  I haven’t gotten around to taking some nice pictures of the new car yet either.

My PLEX Library is now up to over 480 films, and more than 2000 episodes of 110 different TV Series’.  I’m working my way through my DVD’s slowly, but I’ve not found a way to Rip them that’s totally to my liking as yet; my current process is fairly slow, and results in files that are rather larger than I would like!

Anyway, I’ve decided to try and re-boot my technical interest once again. I made the decision some years ago that I’d allow myself to be drawn in to the world of Management rather than being a tecchie, and while I don’t necessarily regret that decision, I have found of late that I feel as though I’m loosing some of the technical skills which allow me to add my particular value in the role that I currently hold, so I’ve signed up for a year’s licence for Cisco’s VIRL programme, so that I can play with, and brush up on some of the newer solutions that I’ve missed out on in recent years, including NX-OS, and IOS-XE, as well as allowing me to play with F5’s, and Palo Alto firewalls in their virtual flavours.  I’ll endeavour to report back here on my findings, and any useful technical blurb that I find, in the hope that at some point, someone might find it useful.

So, following hot on the heels of this post will be my first technical issue, identified while preparing to set up VIRL under VMWare Workstation for the first time.